編集可能

情強ツール"TwiProwl"導入手順のまとめ

情強ツール"TwiProwl"導入手順を @hitoriblog さんが連続ツイートしてくださったのでまとめてみた。
5

情強ツール”TwiProwl”導入手順を @hitoriblog さんが連続ツイートしてくれたのでトゥギャってみた

moyashi @hitoriblog

TwiProwlですねわかります

2011-06-05 00:15:36
hondamarlboro @hondamarlboro

TwiProwlってストリーミングAPI使えるの?

2011-06-05 00:21:25
moyashi @hitoriblog

むしろTwiProwlはStreaming APIとともに爆誕した

2011-06-05 00:24:56
moyashi @hitoriblog

TwiProwlでRegexpMatchすればゆれくる通知できんじゃん

2011-06-05 00:48:04
たかみぃ @takamii

最新のTwiProwlはユーザ名とか検索文字列でもひっかけれるぞ!おらまだ最新に上げてないから知らないけどw

2011-06-05 00:50:57
moyashi @hitoriblog

sudo aptitude install git-core

2011-06-05 00:51:40
moyashi @hitoriblog

ここ行ってログインしてAPI Keyコピーしてくる https://www.prowlapp.com/api_settings.php

2011-06-05 00:55:56
たかみぃ @takamii

ちなみにさくらレンサバではデーモンもーどではうまく動かなかった。そしてサーバに常駐してるプロセスは24hたつとkillされるみたいなんでプロセスの常駐を確認するバッチをcronでまわしてるw

2011-06-05 00:57:37
moyashi @hitoriblog

API Keyをconfig.yamlにペーストしたら保存してvi終了(この時点で大分振り落としてる)

2011-06-05 00:57:48
moyashi @hitoriblog

require 'optparse'の前にrequire 'rubygems'を追記

2011-06-05 01:06:30
moyashi @hitoriblog

vi config.yaml でさっき変更し忘れたUser: のところを自分のscreen nameにする

2011-06-05 01:09:25
moyashi @hitoriblog

./twiprowl これでとりあえず実行できる

2011-06-05 01:09:42
moyashi @hitoriblog

ruby1.8だとこれやんないと動かない。ruby 1.9からはrequire 'rubygems'いらなくなった

2011-06-05 01:10:11
moyashi @hitoriblog

daemonとして動き出すのでプロンプト戻ってくる。ps ax | grep -i twiprow[l]で動作が確認できる

2011-06-05 01:14:02
たかみぃ @takamii

さくらのデフォルトのrubyは1.8だから1.9のソースを取ってきて入れるといいよ。

2011-06-05 01:15:18
moyashi @hitoriblog

このシェルスクリプトをTwiProwlのディレクトリとかに保存 https://gist.github.com/1008056

2011-06-05 01:57:54
残りを読む(6)

コメント

hondamarlboro @hondamarlboro 2011年6月5日
twiprowlの起動状態を監視してくれるスクリプトの追記
0
hondamarlboro @hondamarlboro 2011年6月5日
crontab -e の"2>&1"の場所の修正ツイートを追加
0