2013年6月12日

さよならTwitter API v1.0

本当は阿鼻叫喚なパブリックタイムラインの様子も拾いたかったのですが、多すぎて(苦笑)。これで勘弁してください。
19

今日でお別れね

Twitter API @TwitterAPI

API v1 Retirement will happen today, beginning sometime after 1:30PM PDT. We'll tweet as we ramp up. What to expect: https://t.co/WyWlFwutwb

2013-06-12 04:51:23
TweetbotJP(公認非公式) @TweetbotJP

https://t.co/O1gOtUqUs2 本日をもってAPI v1.0は完全に停止される、とのことです。時刻的には米太平洋時間で13:30以降とのことですので、日本時間では05:30以降ですかね

2013-06-12 04:54:50

予定より少々遅れて停止作業開始

Twitter API @TwitterAPI

We're starting the retirement process a little later than expected; we'll tweet as we begin closer to 2:30pm.

2013-06-12 06:15:09
受信トラフィックが410(HTTPステータスコード:消滅)化される
Twitter API @TwitterAPI

We will begin 410ing inbound API v1 traffic now. We will gradually ramp up over the next several minutes. More info: https://t.co/WyWlFwutwb

2013-06-12 06:29:13
旧型ウィジェットが使用不可に
Twitter API @TwitterAPI

If you were using a legacy widget that no longer functions after API v1 retirement, we suggest using https://t.co/QOpRs58lAk instead.

2013-06-12 06:42:22
検索APIを含むすべての受信リクエストが410化される
Twitter API @TwitterAPI

The retirement of API v1 continues. Most inbound requests should now see HTTP 410, including to the old Search API. https://t.co/WyWlFwutwb

2013-06-12 06:54:01
合わせてストリーミングAPIのベーシック認証も停止
Twitter API @TwitterAPI

As part of the retirement plan today, we're also about to discontinue Basic Auth support for unelevated Streaming API roles. Use OAuth 1.0A.

2013-06-12 06:58:42

そして伝説へ(違

Twitter API @TwitterAPI

Thanks everyone! API v1 Retirement is complete. Please use API v1.1 instead. https://t.co/SIzTAymJPW

2013-06-12 07:26:50
TweetbotJP(公認非公式) @TweetbotJP

https://t.co/rMvIcokXir 日本時間で07:30のちょっと前をもちまして、API v1.0が完全に停止されたようです。

2013-06-12 09:11:09
Twitter Dev Japan @TwitterDevJP

API v1を利用できなくなりました。API v1を使うリクエストはサーバーが410エラーを返します。API v1.1をご利用ください。 ストリーミングAPIの一般アクセスはベーシック認証を利用できなくなりました。OAuthをご利用ください。

2013-06-12 10:34:08

コメント

泉㌠智紀 @jsdfq43wtr 2013年6月12日
今朝慌てたましたよまったく. 前から対処しとけばよかった.
0
ちんあなご(PPM) @hy_cl 2013年6月12日
Windows Mobile端末なんて物持ちのいい方へお知らせ。今のところクライアントはありません。Webブラウザで対応してくださいorz
0
reesia @reesia_T 2013年6月12日
今まで使っていたクライアントは早々にXPを切り捨ててくれたから、早くv1.1対応のクライアントを探さなきゃ。
0
内赤RS 💉PPM(漂流中 @uchiakars 2013年6月12日
どういう訳かまだ純正クライアントは使えているけど(V3.3.3)、これもそのうち止まるのだろうな。
0
cinefuk 🌀 @cinefuk 2013年6月12日
#WS027SH 含め、我々Windows Mobile端末ユーザはAPI 1.1対応のAzurea1.4.4.Betaを使いましょう。 http://adeslab.web.fc2.com/azurea.html
1
cinefuk 🌀 @cinefuk 2013年6月12日
Azurea.1.4.4.Beta15aをダウンロード。これでまた暫く生き延びられる。 http://bit.ly/eL7S95 #WS027SH
1
ちんあなご(PPM) @hy_cl 2013年6月15日
cinefuk ありがとうありがとうありがとうありがとう!
0