【技術情報】 iOS4対応のSDK(XCode3.2.3)で、iPhone3.2以前のプロジェクトが読み込めない場合の対処方法のまとめ

Twitter上で助けてもらった話ですが、他にも困っている方がいるかもしれませんので まとめとして情報を公開したいと思います。 ちなみに私のケースでは、結果として以下の手順でiPhone3.0ターゲットの プロジェクトをXCode3.2.3でビルドできる様になりました (以下、対処方法) iPhoneアプリをiOS4対応SDKで読み込んだ際に 「base sdk missing」と出た際の対応方続きを読むTwitter上で助けてもらった話ですが、他にも困っている方がいるかもしれませんので まとめとして情報を公開したいと思います。 ちなみに私のケースでは、結果として以下の手順でiPhone3.0ターゲットの プロジェクトをXCode3.2.3でビルドできる様になりました (以下、対処方法) iPhoneアプリをiOS4対応SDKで読み込んだ際に 「base sdk missing」と出た際の対応方法 1、XCodeの左のツリーにおいて、 「ターゲット」の下のプロジェクト名を右クリックして 「情報を見る」を選択する 2、ベースSDKをiPhoneデバイス3.2に変える (ReleaseとDebugと両方共に「iPhoneデバイス3.2」に変える) (※)iPhone OS Deployment Targetは3.0のままにする 3、これで、シミュレータでは3.2と4.0が選べるようになる Deployment Targetは3.0のままなので、互換性は変わっていないはずです
iPad iPhone iOS 4
khb02323 5897view 0コメント
3
ログインして広告を非表示にする

コメント

カテゴリーからまとめを探す

「芸能」に関連するカテゴリー

ログインして広告を非表示にする
ログインして広告を非表示にする