Dart Meetup Tokyo #1 の当日の様子

1
Laco @laco0416

開始前ですが会場でもくもくしたい方はフライングOKです〜 呼んでもらえれば迎えに行きます #dart_meetup_tokyo

2015-06-06 12:52:36
Laco @laco0416

dart dev compiler初めて試したけどdart:mirrors使っても割と速いな #dart_meetup_tokyo

2015-06-06 13:19:05
takyam(たくやむ) @takyam

pub build すると main(){} があるやつが *.jsになる。あとは依存されてればコンパイル後のJSに含まれるし無ければ含まれない。--mode debug で開発すすめてリリース時は --mode release #dart_meetup_tokyo

2015-06-06 14:15:56
takyam(たくやむ) @takyam

dart2jsは pub build から叩かれて、設定は pubspec.yaml で設定する。 minifyオプションないとminifyされない。結構細かく設定できそう。すてき。 #dart_meetup_tokyo

2015-06-06 14:17:20
takyam(たくやむ) @takyam

dart2js は寿命が今年で終わり、来年からはDevCompiler #dart_meetup_tokyo

2015-06-06 14:17:43
takyam(たくやむ) @takyam

carret syntax で指定すると semantic version に準拠していいかんじに解決してくれる。バージョニングには気をつけなきゃねー的な。 #dart_meetup_tokyo

2015-06-06 14:21:27
takyam(たくやむ) @takyam

まだpubspec.yaml手書きしてるの!? #dart_meetup_tokyo

2015-06-06 14:22:06
takyam(たくやむ) @takyam

den install hoge でhogeをインストールしてくれる。 #dart_meetup_tokyo

2015-06-06 14:22:36
takyam(たくやむ) @takyam

den bump すればパッケージ配布時にいい感じにしてくれる #dart_meetup_tokyo

2015-06-06 14:24:16
ntaoo @ntaoo

#dart_meetup_tokyo den pub.dartlang.org/packages/den semvarにしたがってバージョニング、インストール支援。 知らなかった。

2015-06-06 14:25:34
takyam(たくやむ) @takyam

pub global run hoge:foo めんどいので pub global activate hoge --excutable=foo --overwrite すると ~/.pub-cache に foo が追加されooで実行できる #dart_meetup_tokyo

2015-06-06 14:28:20
takyam(たくやむ) @takyam

pubspec.yaml に excutables を定義することで使う側は細かいこと気にせんでよいのでpub公開する側は書いてあげようね #dart_meetup_tokyo

2015-06-06 14:29:05
takyam(たくやむ) @takyam

dart foo.dart と pub global run foo はちょっと実行環境が違う。 Platform.script.path とかの値が変わっちゃうので超注意。 #dart_meetup_tokyo

2015-06-06 14:30:55
takyam(たくやむ) @takyam

pubの検索は以前みた感じGoogleCustomSearch使ってるみたいです github.com/dart-lang/pub-… #dart_meetup_tokyo

2015-06-06 14:49:52
残りを読む(60)

コメント

コメントがまだありません。感想を最初に伝えてみませんか?